Skip to main content
Skyhigh Security

Upgrade Client Proxy to 4.6.0 and later on macOS

Client Proxy for macOS 4.6.0 and later supports Apple's native M1 and M2 chip on macOS.  To ensure a seamless experience while upgrading Client Proxy 4.6.0, ensure all applicable products in your environment are upgraded to the latest available version in the below mentioned sequence:

NOTE: Disregard any products not used in your environment. 

  • Begin by upgrading Trellix Agent to the latest version 
  • Install the latest version of Trellix ENS for Mac  

  • Install the latest version of Skyhigh Client Proxy (SCP)  

  • Install the latest version of Trellix Endpoint Detection and Response (EDR)  

  • Install the latest version of Trellix Data Loss Prevention (DLP)  

  • Install the latest version of Trellix Management for Native Encryption (MNE)  

  • Install the latest version of Trellix File and Removable Media Protection (FRP)  

  • Install the latest version of Trellix Policy Auditor (PA)  

Do I need to upgrade right away? 

No, if you are not prepared to upgrade, you can choose to do so at a later time.  When you do upgrade, please ensure you follow the above-mentioned process. Remember, upgrading one of the affected products on a device will require upgrading all affected products on that device. 

Can I do the upgrade in phases? 

It is not possible to perform this upgrade in phases. When one of the affected products is upgraded, all others are no longer compatible with the M1 and M2 codebase, and are removed. The latest available version of those other affected products should then be installed.

What are the supported upgrade versions?
Client Proxy version Supported upgrade version
4.5 4.6.0, 4.6.1, 4.7.0
4.6 4.6.1, 4.7.0, 4.8.0

NOTE:

  • Was this article helpful?