Skyhigh Client Proxy disconnects from the proxy and no longer retries
Problem:
You see Skyhigh Client Proxy (SCP) unable to connect to proxy and stops retrying. Further analysis shows log messages such as
- [ma_app]failed to open registry McAfee\Agent\, error(2), waiting for registry key to be re-established
Cause:
NetworkManager threads in SCP were being found in hung state while doing a captive portal check
Solution:
Resolved in MCP-6978 as per https://success.skyhighsecurity.com/..._Release_Notes
Workaround:
Until on a released version with the fix, customers may:
- Create a test policy with access protection disabled to allow the SCP service to restart.
- Save the test policy to C:\ProgramData\Skyhigh\SCP\Policy\Temp and back up the previous policy.
- On the client system, perform the taskkill command found here (not copied directly as it has advise about frequency of using command): https://success.skyhighsecurity.com/...ndpoint_system
- The SCP service will restart.
- Remove the test policy and restore the previous policy to enable access protection.
Related Jira: