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Skyhigh Security

Troubleshoot PAC file issues

Category: 

Troubleshooting

How to

Environment

Secure Web Gateway (SWG) On-premise

PAC file

Problem

Client machines are unable to download or retrieve the PAC file hosted on the SWG.

Cause

  • Misconfiguration (SWG or Client-side)
  • Port/Network issue

Log Collection: 

  • Feedback file
  • Client-side Wireshark capture 
  1. Close all browser
  2. Start Wireshark
  3. Open browser

 

Log Analysis (Optional): 

 

Review pac file configuration

  1. Ensure the HTTP and/or HTTPS connector is enabled and configured with the appropriate format <proxy_IP>:<PORT>

  1. PAC file should be stored in correct directory (ls /opt/mwg/files)

  1. Client machine should point to the correct script address.

    • <http:// or https://><proxy_IP:port>/files/<name of file>

 

If there are no misconfigurations, ensure the <proxy_IP:port> is open.

  • Run netstat -anp | grep :<PORT> 

  • Or review \mlos\netstat_anp in feedback file

The port should be open and in the “listen” state to allow clients to connect and retrieve the PAC file.

The mwg-ui service must be active as it hosts the PAC file

 

If the port/Java process is NOT listening/running, review the mwg-ui logs:

  • \mlos\systemctl_status_mwg 

  • Service mwg-ui status

 

If the Java process is running/listening, review the packet capture.

  • Reviewing the 200 OK shows the PAC file text

 

Solution: 

  1. Review and correct any misconfigurations on either the client or SWG. 
    1. HTTP and/or HTTPS must be enabled and configured with an IP and port
    2. PAC file must be hosted and stored in the correct directory
    3. Client machine must point to the PAC file stored on the SWG
  2. Ensure the port is open and listening 
    1. If the port is not listening, review the mwg-ui service, as it is required to be active
    2. If the port is listening review possible network issues

 

As the mwg-ui service is required to allow clients to download the PAC file, any mwg-ui service issues will cause PAC file retrieval issues. Allocating more memory to the UI would be beneficial to avoid any mwg-ui downtime. Review the Configuration > User Interface  > Amount of maximum memory available for mwg-ui backend. 

  • Default allocated memory: 512
  • Recommended memory: 2048

 

 

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