Troubleshoot PAC file issues
Category:
Troubleshooting
How to
Environment:
Secure Web Gateway (SWG) On-premise
PAC file
Problem:
Client machines are unable to download or retrieve the PAC file hosted on the SWG.
Cause:
- Misconfiguration (SWG or Client-side)
- Port/Network issue
Log Collection:
- Feedback file
- Client-side Wireshark capture
- Close all browser
- Start Wireshark
- Open browser
Log Analysis (Optional):
Review pac file configuration
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Ensure the HTTP and/or HTTPS connector is enabled and configured with the appropriate format <proxy_IP>:<PORT>
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PAC file should be stored in correct directory (ls /opt/mwg/files)
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Client machine should point to the correct script address.
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<http:// or https://><proxy_IP:port>/files/<name of file>
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If there are no misconfigurations, ensure the <proxy_IP:port> is open.
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Run netstat -anp | grep :<PORT>
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Or review \mlos\netstat_anp in feedback file
The port should be open and in the “listen” state to allow clients to connect and retrieve the PAC file.
The mwg-ui service must be active as it hosts the PAC file
If the port/Java process is NOT listening/running, review the mwg-ui logs:
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\mlos\systemctl_status_mwg
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Service mwg-ui status
If the Java process is running/listening, review the packet capture.
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Client is unable to connect to <proxy_IP:port>; therefore, unable to retrieve PAC file:
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Successful PAC file download
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Reviewing the 200 OK shows the PAC file text
Solution:
- Review and correct any misconfigurations on either the client or SWG.
- HTTP and/or HTTPS must be enabled and configured with an IP and port
- PAC file must be hosted and stored in the correct directory
- Client machine must point to the PAC file stored on the SWG
- Ensure the port is open and listening
- If the port is not listening, review the mwg-ui service, as it is required to be active
- If the port is listening review possible network issues
As the mwg-ui service is required to allow clients to download the PAC file, any mwg-ui service issues will cause PAC file retrieval issues. Allocating more memory to the UI would be beneficial to avoid any mwg-ui downtime. Review the Configuration > User Interface > Amount of maximum memory available for mwg-ui backend.
- Default allocated memory: 512
- Recommended memory: 2048